Need help? Chat now!

Hostwinds 教程

寻找结果为:


目录


使用MultiPHP更改PHP版本

如何更改每个域的PHP版本

标签: cPanel 

使用MultiPHP更改PHP版本

如果单个cPanel帐户上有大量域,则可能需要设置一个用于每个域名的不同PHP版本。 这可能是由于不同PHP版本的依赖性问题导致您的网站无法正常工作。 例如,PHP mysql_ PHP 7中不推荐使用和删除这些函数。幸运的是,有一种称为MultiPHP的东西可以轻松解决这一问题。

MultiPHP仅使用EasyApache 4安装Apache 4.如果您过去使用EasyApache 3,则仍然可以升级到EasyAcache 4以利用此功能。 MultiPHP允许您使用CPanel帐户的域轻松设置单个PHP版本和配置。

使用MultiPHP更改PHP版本

在继续下面的步骤之前,首先,您需要在CPanel中使用EasyApache 4。 我们的所有新购买的托管计划(如我们的共享和业务托管)都将默认拥有这一点。

  1. 首先登录CPANEL帐户。
  2. 登录后,您将想要导航 软件 部分并找到 MultiPHP管理器 图标。 点击那个。
  1. 单击此后,您将被带到另一个页面。 在此页面中,您将能够选择您域将使用的PHP版本。 为此,您会选择 复选框 域名左侧(如果需要,您可以选择多个域)。 然后在右上角,选择要用于该域的PHP版本。 选择了要使用的版本后,可以按 应用 按钮。 从现在开始,这将使该域使用该版本的PHP。 系统PHP版本也显示在此页面上。 如果未在此页面上手动设置任何版本,则此版本将自动使用。
  1. 应用于域的更改后,它现在应该使用所选的PHP版本加载并将其更改为。

如果您有任何疑问或想要帮助,请通过实时聊天或通过 提交票证 与我们的技术支持团队。

撰写者 Michael Brower  /  九月 5, 2017