Need help? Chat now!

Hostwinds 教程

寻找结果为:


目录


最低系统要求

Magento系统要求

标签: Magento 

最低系统要求

要在任何系统上顺利运行,Magento将拥有一组最低和建议的要求。为用户在自己的服务器上安装Magento以了解要分配的内容的用户提供最低要求。在此,本指南是为Magento 1.9.x编写的,其中x可能是此主要社区版本中的任何数字。

最低系统要求

内存: Magento在服务器上需要至少512MB的RAM才能正常运行。 但是,建议至少有1GB的RAM以获得更好的性能。

LAMP或LEMP环境: 这意味着在这种类型的Web环境中通常最佳地表现最佳。 灯代表Linux,Apache,MySQL和PHP。 与此同时,LEMP适用于Linux,Nginx,MySQL和PHP。 我们目前没有在我们可用的共享和业务托管计划上使用Nginx。 但是,灯具的要求与我们最新的托管计划满足。

操作系统: Magento要求将其安装在具有x86体系结构的Linux服务器上。 这意味着它将无法安装在Windows操作系统上。 我们当前的托管计划(例如共享和企业托管)也可以满足此要求。

Web服务器版本: 由于Magento支持不同的Web服务器,因此它需要不同的版本。

阿帕奇: 使用Apache,Magento将要求使用至少版本2.x,其中X将是一个数字,以便进一步指定Apache的版本。 目前,我们的较新的托管计划利用版本2.4,因此这不是一个问题。

Nginx: 对于nginx,Magento要求使用至少版本1.7.x,x是一个数字来指定nginx版本。 我们的托管计划默认情况下不使用nginx,但如果在VPS,云或专用服务器上,则您可以root访问权限来安装Web服务器,如nginx。

PHP版本: Magento表示它需要至少php 5.4,5.4,5.5或5.6来运行。 通过新的共享和业务托管计划,您将能够使用PHP 5.6版,以及7.0。

PHP模块: PHP使用模块来实现某些附加功能。 Magento利用此功能提供了许多功能。 这些都将在我们的共享和业务托管计划中启用。

  • PDO_MySQL
  • simplexml.
  • 加密
  • 杂凑
  • GD
  • DOM
  • 图标
  • 肥皂
  • 卷曲

数据库: 对于Magento的数据库,它使用MySQL(以及MariaDB)。

  • MySQL版本: Magento需要MySQL 5.6版

SSL: 虽然不是必需的,但SSL大量建议使用Magento,因为它将作为店面行为。 您希望确保所有客户端的信息都安全和加密。

Hostwinds提供的任何Linux Web托管程序包都可以满足这些要求。

如果您对Magento有其他疑问,请通过在线聊天与我们联系,致电我们或 提交票证 与我们的技术支持团队。

撰写者 Hostwinds Team  /  四月 10, 2018