Need help? Chat now!

Hostwinds 教程

寻找结果为:


目录


Joomla! 基本系统要求
Joomla! 推荐系统要求

Joomla! 系统要求

标签 Joomla 

Joomla! 基本系统要求
Joomla! 推荐系统要求

安装Joomla时,Joomla必须满足的某些要求,因为有不同版本的Joomla。本文的编写为在撰写本文时对最新版本有用。这是Joomla 3.x,其中x是一个有助于描述当前版本的数字。下面列出了Joomla对功能的基础和建议要求。

Joomla! 基本系统要求

  • PHP版本: 必须高于PHP版本5.3.10。 早已不推荐使用此版本,因此这应该不是问题。 我们所有的新主机计划均未安装此版本。
  • 数据库: Joomla支持不同类型的数据库。 支持的数据库是MySQL / MariaDB,MS SQL Server和PostgreSQL
    • MySQL / MariaDB: 必须高于5.1版。 我们的新主机计划中不存在的另一个版本。
    • MS SQL Server: 必须高于10.50.1600.1版本
    • PostgreSQL: 必须高于版本8.3.18
  • 网络服务器: 随着Joomla支持的不同类型的数据库,还有不同的Web服务器。 这些包括Apache,Nginx和Microsoft IIS(适用于Windows VPS)
    • 阿帕奇: 它必须高于2.0版本。 我们的共享/业务托管计划将始终具有相对最新版本的Apache,因此这不是问题。
    • Nginx: 必须高于1.0版。 我们目前不使用nginx。 但是,这仍然是VPS和专用服务器的选项。
    • Microsoft IIS: 必须是版本7.但是,这将是Windows操作系统当前仅在Windows VPS或专用服务器上可用的Windows操作系统。

Joomla未指定服务器的任何特定要求,例如RAM甚至CPU。 但是,如果您倾向于与Joomla网站遇到性能问题,可能是因为缺乏资源。

除了Joomla的基础系统要求,也可能有推荐的选项。 基本要求是最小的,看看Joomla是否会在系统上运行。 然而,这并不意味着Joomla将最佳地或良好地运行。 您可以在下面的列表中找到Joomla的推荐要求。

Joomla! 推荐系统要求

  • PHP版本: Joomla建议您使用5.6和UP或7.0和UP的PHP版本。
  • 数据库:
    • MySQL / MariaDB: 建议高于MySQL 5.5.3
    • MS SQL Server: 还建议高于10.50.1600.1
    • PostgreSQL: 建议高于9.1版
  • 网络服务器:
    • 阿帕奇: 建议高于Apache 2.4。 我们较新的托管计划将满足此建议
    • Nginx: 推荐高于1.8版本
    • Microsoft IIS: 对于Joomla,他们建议仅使用版本7

Hostwinds提供的任何Linux Web托管程序包都可以满足这些要求。

如果您应该有任何其他问题,请随时通过我们的实时聊天或提交联系我们 一张票.

撰写者 Hostwinds Team  /  三行 31, 2018